Fix Youtube glitch showing green screen rather than video

June 2, 2012



You are probably here because your Youtube decides to show you a green screen rather than the actual video. You may have realized that you can hear the audio perfectly. This annoying glitch is very common, it is very likely to happen after upgrading to Windows 8.

So here is a simply tutorial on how to fix this glitch.



Whenever you launch a video such as the one shown below (this is one that I made!) you receive this green colour that covers your video. All you have to do is right click on the green area and click on "Settings".


You will get this small popup, all you have to do is untick the "Enable hardware acceleration" option.


Now refresh the page and your video is working! You only need to do this once and it will work for all your videos!


So I hope I helped you fix your Youtube. If you're still having problems tell me in the comments and I will be quick to help. And please consider sharing this useful tip with your friends using any of the share buttons below.

11 comments:

  1. I still get the green screen even after I do this :( I refreshed, Reinstalled flash and chrome. I have no Idea what to do, and yes I have even updated drivers.

    ReplyDelete
    Replies
    1. Did you try using a different browser to see where the problem is coming from?

      Delete
  2. I don't have those options when going to settings. It only has 4 tabs, not five like the picture.

    ReplyDelete
    Replies
    1. I just checked and I have 5 tabs. Which browser are you using? And do you have the latest version of Adobe Flash?

      Delete
    2. I have windows 8, internet explorer 10 and my adobe flash is 11.6.602.171

      Delete
    3. Try it with another browser. And also look for this toggle in your 4 tabs they might have moved it somewhere else

      Delete
  3. Hi,
    Under the Adobe Flash Player Settings, I don't have a Display tab; therefore, I don't have the option to uncheck "Enable Hardware Acceleration." Please help. Thanks

    ReplyDelete
    Replies
    1. Hi, which version of Windows, and what browser are you using?

      Delete
  4. This didn't work for me it didn't show the enable hardware acceleration

    ReplyDelete

What do you think? Share a comment!

Follow

fb twitter google rss youtube